python-browser-history-merger/PKGBUILD
2024-06-07 18:59:00 +09:00

37 lines
871 B
Bash

# Maintainer: qwjyh <urataw421 at gmail dot com>
# TODO: Fix doc gen and test
pkgname=python-browser-history-merger
_pkgname="${pkgname#python-}"
pkgver=0.1.0
pkgrel=1
pkgdesc="Simple tool to merge browser histories into a single database"
depends=('python')
makedepends=('python-build' 'python-installer' 'python-wheel')
arch=('any')
url="https://github.com/qwjyh/browser-history-merger"
license=('MIT')
source=("https://github.com/qwjyh/browser-history-merger/archive/refs/tags/v0.1.0.tar.gz")
sha256sums=('2133c771fc7347f4907a34f00c7815917f93f67f59233116c1141a17e27c25cd')
_distdir="$_pkgname"
build() {
cd "$srcdir/$_distdir"
python -m build --wheel --no-isolation
}
check() {
cd "$srcdir/$_distdir"
# TODO: Fails
# ninja test
}
package() {
cd "$srcdir//$_distdir"
python -m installer --destdir="$pkgdir" dist/*.whl
}
# vim: sw=2: