servitor-bin/PKGBUILD
2024-08-05 17:29:21 +02:00

27 lines
742 B
Bash
Raw Permalink Blame History

This file contains ambiguous Unicode characters

This file contains Unicode characters that might be confused with other characters. If you think that this is intentional, you can safely ignore this warning. Use the Escape button to reveal them.

# Maintainer: qwjyh <urataw421 at gmail dot com>
pkgname=servitor-bin
_pkgname=servitor
pkgver=3
pkgrel=1
pkgdesc="A command-line Fediverse client that doesnt require a server"
arch=('x86_64' 'arm64')
url="https://github.com/BentonEdmondson/servitor"
license=('GPL-3.0-only')
makedepends=()
optdepends=()
source=("https://github.com/BentonEdmondson/servitor/releases/download/v$pkgver/servitor.linux.$CARCH")
# sha256sums=('5387a1f240c0bedc0693fbc609a948803e44cb6a6e1dfee908b11d51fdfcfbac')
case "${CARCH}" in
'x86_64')
sha256sums=('7de82bb60850a40504a5005695d4109196b521501ae87106c10ea59377494cf4')
;;
'arm64')
;;
esac
package() {
install -Dm755 "servitor.linux.${CARCH}" "${pkgdir}/usr/bin/${_pkgname}"
}
# vim: sw=2: