Update to v4.29_9680-1
This commit is contained in:
parent
3b33e93066
commit
074e3dc716
4 changed files with 23 additions and 115 deletions
22
.SRCINFO
22
.SRCINFO
|
@ -1,28 +1,26 @@
|
|||
pkgbase = softethervpn
|
||||
pkgdesc = Multi-protocol VPN Program from University of Tsukuba
|
||||
pkgver = v4.25_9656
|
||||
pkgrel = 5
|
||||
url = http://www.softether.org/
|
||||
pkgver = v4.29_9680
|
||||
pkgrel = 1
|
||||
url = https://www.softether.org/
|
||||
arch = i686
|
||||
arch = x86_64
|
||||
arch = aarch64
|
||||
arch = armv7h
|
||||
license = GPL
|
||||
license = Apache
|
||||
depends = bash
|
||||
depends = openssl
|
||||
depends = zlib
|
||||
source = http://www.softether-download.com/files/softether/v4.25-9656-rtm-2018.01.15-tree/Source_Code/softether-src-v4.25-9656-rtm.tar.gz
|
||||
source = https://github.com/SoftEtherVPN/SoftEtherVPN_Stable/releases/download/v4.29-9680-rtm/softether-src-v4.29-9680-rtm.tar.gz
|
||||
source = aarch64.patch
|
||||
source = openssl.patch
|
||||
source = softethervpn-bridge.service
|
||||
source = softethervpn-client.service
|
||||
source = softethervpn-server.service
|
||||
sha1sums = 5ceb11866af212278c8a151bb40a2a048bdd7fea
|
||||
sha1sums = 75d351833c41ee4c54d4ad18dde678e6df47e220
|
||||
sha1sums = 59565cedebeb65452aed776b582bc3b833872686
|
||||
sha1sums = 12a3919aabcdd7531320056a4b43072892232925
|
||||
sha1sums = ba594c7defb52548369726c56e2cad633019abef
|
||||
sha1sums = 06cd320553daf0dffdf6a81a22d630fbe211fc33
|
||||
md5sums = 0b0bf86c59374f5ea1dbde20b3a3b5d3
|
||||
md5sums = 8b92f69f9d8d852a3739d0e48bad0454
|
||||
md5sums = 1d54c0065ae8947bd8455b9e2050c1af
|
||||
md5sums = a1134fea991e6e00dc4910b1be16dc73
|
||||
md5sums = b54b4f68d56555ddfffc50c2c399624f
|
||||
|
||||
pkgname = softethervpn
|
||||
|
||||
|
|
27
PKGBUILD
27
PKGBUILD
|
@ -1,30 +1,27 @@
|
|||
# Maintainer: Tun Win Naing <twnaing(at)outlook(dot)com>
|
||||
# Maintainer: Jonathan Liu <net147@gmail.com>
|
||||
pkgname=softethervpn
|
||||
pkgver=v4.25_9656
|
||||
pkgrel=5
|
||||
pkgver=v4.29_9680
|
||||
pkgrel=1
|
||||
pkgdesc="Multi-protocol VPN Program from University of Tsukuba"
|
||||
arch=('i686' 'x86_64' 'aarch64' 'armv7h')
|
||||
source=('http://www.softether-download.com/files/softether/v4.25-9656-rtm-2018.01.15-tree/Source_Code/softether-src-v4.25-9656-rtm.tar.gz'
|
||||
url="https://www.softether.org/"
|
||||
license=('Apache')
|
||||
depends=('bash' 'openssl' 'zlib')
|
||||
source=("https://github.com/SoftEtherVPN/SoftEtherVPN_Stable/releases/download/${pkgver//_/-}-rtm/softether-src-${pkgver//_/-}-rtm.tar.gz"
|
||||
'aarch64.patch'
|
||||
'openssl.patch'
|
||||
'softethervpn-bridge.service'
|
||||
'softethervpn-client.service'
|
||||
'softethervpn-server.service')
|
||||
sha1sums=('5ceb11866af212278c8a151bb40a2a048bdd7fea'
|
||||
'75d351833c41ee4c54d4ad18dde678e6df47e220'
|
||||
'59565cedebeb65452aed776b582bc3b833872686'
|
||||
'12a3919aabcdd7531320056a4b43072892232925'
|
||||
'ba594c7defb52548369726c56e2cad633019abef'
|
||||
'06cd320553daf0dffdf6a81a22d630fbe211fc33')
|
||||
license=('GPL')
|
||||
depends=('bash' 'openssl' 'zlib')
|
||||
url="http://www.softether.org/"
|
||||
md5sums=('0b0bf86c59374f5ea1dbde20b3a3b5d3'
|
||||
'8b92f69f9d8d852a3739d0e48bad0454'
|
||||
'1d54c0065ae8947bd8455b9e2050c1af'
|
||||
'a1134fea991e6e00dc4910b1be16dc73'
|
||||
'b54b4f68d56555ddfffc50c2c399624f')
|
||||
|
||||
build(){
|
||||
cd "${srcdir}/${pkgver//_/-}"
|
||||
patch -Np1 -i "${srcdir}/aarch64.patch"
|
||||
patch -Np1 -i "${srcdir}/openssl.patch"
|
||||
|
||||
if [ "${CARCH}" == "i686" ]; then
|
||||
cp src/makefiles/linux_32bit.mak Makefile
|
||||
|
@ -57,3 +54,5 @@ package(){
|
|||
install -d "${pkgdir}"/usr/lib/systemd/system
|
||||
install -Dm644 "${srcdir}"/*.service "${pkgdir}"/usr/lib/systemd/system
|
||||
}
|
||||
|
||||
# vim:set ts=2 sw=2 et:
|
||||
|
|
|
@ -1,24 +0,0 @@
|
|||
--- a/src/Mayaqua/Network.c 2016-03-20 13:37:38.829534634 -0400
|
||||
+++ b/src/Mayaqua/Network.c 2016-03-20 13:37:28.079218703 -0400
|
||||
@@ -12981,14 +12981,14 @@
|
||||
}
|
||||
else
|
||||
{
|
||||
- if (client_tls == false)
|
||||
- {
|
||||
- SSL_CTX_set_ssl_version(ssl_ctx, SSLv3_method());
|
||||
- }
|
||||
- else
|
||||
- {
|
||||
+ //if (client_tls == false)
|
||||
+ //{
|
||||
+ // SSL_CTX_set_ssl_version(ssl_ctx, SSLv3_method());
|
||||
+ //}
|
||||
+ //else
|
||||
+ //{
|
||||
SSL_CTX_set_ssl_version(ssl_ctx, TLSv1_client_method());
|
||||
- }
|
||||
+ //}
|
||||
}
|
||||
sock->ssl = SSL_new(ssl_ctx);
|
||||
SSL_set_fd(sock->ssl, (int)sock->socket);
|
|
@ -1,65 +0,0 @@
|
|||
From 1fad008e1adba5cb596da6f9ec6a244d49a585cf Mon Sep 17 00:00:00 2001
|
||||
From: Davide Beatrici <davidebeatrici@gmail.com>
|
||||
Date: Mon, 9 Apr 2018 22:02:34 +0200
|
||||
Subject: [PATCH] Encrypt: set default RSA key size to 1024 everywhere, using
|
||||
the RSA_KEY_SIZE macro
|
||||
|
||||
This commit also fixes the problem described in #31, which was caused by the test key generated in RsaCheck() being too small for newer OpenSSL versions.
|
||||
---
|
||||
src/Mayaqua/Encrypt.c | 8 ++++----
|
||||
src/Mayaqua/Encrypt.h | 2 +-
|
||||
2 files changed, 5 insertions(+), 5 deletions(-)
|
||||
|
||||
diff --git a/src/Mayaqua/Encrypt.c b/src/Mayaqua/Encrypt.c
|
||||
index 381d1c57..a5570520 100644
|
||||
--- a/src/Mayaqua/Encrypt.c
|
||||
+++ b/src/Mayaqua/Encrypt.c
|
||||
@@ -2194,7 +2194,7 @@ bool RsaVerifyEx(void *data, UINT data_size, void *sign, K *k, UINT bits)
|
||||
}
|
||||
if (bits == 0)
|
||||
{
|
||||
- bits = 1024;
|
||||
+ bits = RSA_KEY_SIZE;
|
||||
}
|
||||
|
||||
// Hash the data
|
||||
@@ -2233,7 +2233,7 @@ bool RsaSignEx(void *dst, void *src, UINT size, K *k, UINT bits)
|
||||
}
|
||||
if (bits == 0)
|
||||
{
|
||||
- bits = 1024;
|
||||
+ bits = RSA_KEY_SIZE;
|
||||
}
|
||||
|
||||
Zero(dst, bits / 8);
|
||||
@@ -2302,7 +2302,7 @@ bool RsaCheck()
|
||||
BIO *bio;
|
||||
char errbuf[MAX_SIZE];
|
||||
UINT size = 0;
|
||||
- UINT bit = 32;
|
||||
+ UINT bit = RSA_KEY_SIZE;
|
||||
// Validate arguments
|
||||
|
||||
// Key generation
|
||||
@@ -2372,7 +2372,7 @@ bool RsaGen(K **priv, K **pub, UINT bit)
|
||||
}
|
||||
if (bit == 0)
|
||||
{
|
||||
- bit = 1024;
|
||||
+ bit = RSA_KEY_SIZE;
|
||||
}
|
||||
|
||||
// Key generation
|
||||
diff --git a/src/Mayaqua/Encrypt.h b/src/Mayaqua/Encrypt.h
|
||||
index d795d2d6..0c481610 100644
|
||||
--- a/src/Mayaqua/Encrypt.h
|
||||
+++ b/src/Mayaqua/Encrypt.h
|
||||
@@ -128,7 +128,7 @@ void RAND_Free_For_SoftEther();
|
||||
#define DES_IV_SIZE 8 // DES IV size
|
||||
#define DES_BLOCK_SIZE 8 // DES block size
|
||||
#define DES3_KEY_SIZE (8 * 3) // 3DES key size
|
||||
-#define RSA_KEY_SIZE 128 // RSA key size
|
||||
+#define RSA_KEY_SIZE 1024 // RSA key size
|
||||
#define DH_KEY_SIZE 128 // DH key size
|
||||
#define RSA_MIN_SIGN_HASH_SIZE (15 + SHA1_HASH_SIZE) // Minimum RSA hash size
|
||||
#define RSA_SIGN_HASH_SIZE (RSA_MIN_SIGN_HASH_SIZE) // RSA hash size
|
Loading…
Reference in a new issue